当页导航

JDK兼容性问题冲突导致启动购买的中间件失败

很多购买的中间件在安装过程中都会默认安装自自带版本JDK,导致兼容性问题,例如IBM Cognos安装时默认是安装自身的JDK,而有些系统购买自己的JDK 例如SUN的,导致启动失败等问题显示全部

很多购买的中间件在安装过程中都会默认安装自自带版本JDK,导致兼容性问题,例如IBM Cognos安装时默认是安装自身的JDK,而有些系统购买自己的JDK 例如SUN的,导致启动失败等问题

收起

5回答

王超王超售后技术支持 , 北京东方宏达信息技术有限公司
chukun402美美的小G等赞同了此回答 
任何WebSphere版本,都会自带JDK,这样就避免了楼主所说的兼容性的问题。WebLogic确实一直都存在JDK兼容性的问题,在安装WebLogic之前,需要自己查阅Oracle提供的官方兼容性文档,提前安装、配置没有问题的JDK版本。...显示全部

任何WebSphere版本,都会自带JDK,这样就避免了楼主所说的兼容性的问题。WebLogic确实一直都存在JDK兼容性的问题,在安装WebLogic之前,需要自己查阅Oracle提供的官方兼容性文档,提前安装、配置没有问题的JDK版本。

收起
答案包含:通用方法 2016-05-27
swallowluoswallowluo系统架构师 , 中国金融电子化公司
泊涯glenzhuhchao等赞同了此回答 
其他的产品不是很清楚,但是每个版本的WAS都会带自己的JDK,而且在WAS 8.5之前不能修改JDK,所以这就对应用开发时提出一定的要求,不要涉及到不同厂家JDK之间的差异,或者在开发的时候,就直接使用IBM的JDK。...显示全部

其他的产品不是很清楚,但是每个版本的WAS都会带自己的JDK,而且在WAS 8.5之前不能修改JDK,所以这就对应用开发时提出一定的要求,不要涉及到不同厂家JDK之间的差异,或者在开发的时候,就直接使用IBM的JDK。

收起
 2016-05-27
YuLiminYuLimin软件开发工程师 , IBM广州
glenzhu泊涯赞同了此回答
WAS 8.5.x.x之后可以选择不同版本的JDK,比如6,7,8显示全部

WAS 8.5.x.x之后可以选择不同版本的JDK,比如6,7,8

收起
 2016-05-27
wodese7enwodese7en其它 , 未知
泊涯赞同了此回答
这个在项目启动前,就应该要考虑到的。显示全部

这个在项目启动前,就应该要考虑到的。

收起
 2016-05-27
yangyayunyangyayun研发工程师 , 科大国创
学习下显示全部

学习下

收起
 2016-06-03

撰写回答

提问者

泊涯系统测试工程师, 高伟达公司
发布166
回答65

请稍候...